This page is obsolete. Please refer to http://pfanne.rzg.mpg.de/trac/openAFS-OSD/wiki/Patches instead.
About the patches
For (my) convenience, I opted to store the patches in form of a mailbox as generated by
git format-patch --stdout
Ideally, you use a git repository and
git checkout -b rxosd-patches openafs-stable-1_4_10 git am <patch-file.mb
You then have all the goodness of git to review the changes.
Alternatively, it shouldn't be too hard to retrieve individual u-diffs from the files.
Notice that updates are most likely rebased, so you should reset --hard to the original pristine state and reapply the whole thing.
Protocol Abstraction Layer: protocol-abstraction-2009-07-01.mb (obsolete)
UPDATE: followed up on Simon's suggestions: protocol-abstraction-2009-07-02.mb
- squashed patches for unification and abstraction
- simplified struct afs_cacheOps
- removed the reference to CACHE_BYPASS
- using void* instead of char* for rocks
- removed changes to afs_stats.h
- don't initialize pointer with 0 but NULL
- omitted excessive casting
- marry storeOps / fetchOps to cacheOps
- initialize storeVariables in cachetype-specific places
- add typing the rxfs_fetchInit protoype
- Protocol Abstraction Layer
Unifies CacheStoreProc / CacheFetchProc routines for UFS- and MemCache, respectively. Encapsules server interactions into discrete functions that are specific to the cache type used. Additional protocols can be added relatively easy then, by defining additional sets of Store/Fetch mini-operations.
Protocol Abstraction layer
The CacheStoreProcs and CacheStoreProcs for the respective cache types are counterintuitively distributed in the source tree. We propose a new afs_fetchstore.c for these.
The caches should use identical Fetch/Store routines. This patch concerns only Store.
StoreOps are yet another differentiation layer underneath cache type abstraction. Interaction with rxosd servers will manifest itself in form of a set of alternative StoreOps.
Note that the ((struct rxfs_storeVariables *)rock)->call = acall; line is actually a hack. The final rxfs_storeInit() will work rather differently than how it does now, so this is my way of bridging the gap.
Make code more readable, and replace some return codes.
The counterparts of rxosd-02 wrt. the CacheFetchProcs.
Another simplification - this comes for free, as without the macros from afs_chunkops.h, the pointers from afs_cacheOps were no longer used for StoreProc / FetchProc.